Download CFinder    Manual    Network Data    Publications    WebCFinder


Home

Download

Publications

Support

People

Links

edit SideBar


CFinder FAQ

Contents (hide)

  1. 1. Visualization
    1. 1.1 How can I view the communities of a selected node?
    2. 1.2 In the manual I can see a "View" menubar item, but it doesn't appear when I start CFinder. Why?
    3. 1.3 How can I use the graph widget of CFinder v1? I want to avoid the dynamic layout.
    4. 1.4 Every time I export a graph, when I open the file it is just a blank page. This happens whatever format I choose for the export (pdf, jpeg, bmp etc...)
    5. 1.5 I can run the command line version but I receive java related errors when I use the graphical user interface.
    6. 1.6 I experience some problem with the CFinder graphical user interface, but I cannot figure out what is the real problem, and I do not know how to report it.
  2. 2. Usage
    1. 2.1 Exact clique finding takes too long. What shall I do?
    2. 2.2 Can I run CFinder directly from another Linux program?
    3. 2.3 Could you provide the java documentation of CFinder? I plan to call it through my own java code.
    4. 2.4 I have calculated the community structure on a big server, and I have problems with loading the results on my terminal
    5. 2.5 I receive a warning in the CFinder window: "user abort". What next?
    6. 2.6 How to get more output from CFinder, why my problem occures?
    7. 2.7 I have a huge graph that does not fit into the memory. What can I do?
    8. 2.8 Under Windows x64 bit I get the message: C++ library not found or other library path problem
    9. 2.9 Under windows I got the Error message: Exception in thread "main" java.lang.NoClassDefFoundError: elte/commuity/visual/MainFrame
    10. 2.10 Can one supress the screen printed output of the CFinderBatch file?
    11. 2.11 How can I export the picture, I see inside the display panel? What I got is only a blank page in the exported file.
    12. 2.12 I received an error message about a licence file. I cannot use the software.
    13. 2.13 How do I find the common elements between overlapping communities?
    14. 2.14 How can I set the intensity threshold for handling weighted (CPMw) networks?
  3. 3. Input format
    1. 3.1 How can I construct a network with CFinder?
    2. 3.2 I use MS Windows with Excel and my network is stored as an adjacency matrix. Can I convert it to a list of links? (This is the input format used by CFinder)
    3. 3.3 I have tried the demo networks in the downloadable zip package. Do you have further networks?
    4. 3.4 I work with matlab. How should I export my graphs for CFinder?
    5. 3.5 I've opened one of the demo input files with NotePad and I see black boxes. What's wrong ?
    6. 3.6 CFinder reads only the first line from the network file and then aborts.
  4. 4. Licence
    1. 4.1 As a non-profit user am I allowed to share files that I created with CFinder?
    2. 4.2 May I use the data sets from the CFinder website and from the downloaded version the demo files? Are they free for non-profit and for commercial usage?
    3. 4.3 Can you send me the source code of CFinder?
    4. 4.4 My licence has expired. How can I uninstall CFinder?
    5. 4.5 My licence key has expired. How can I use your software?
    6. 4.6 Should I be categorized as a commercial user or a not-for-profit user? I use CFinder only for my personal interest in my free time.

1.  Visualization

1.1  How can I view the communities of a selected node?

After computing the communities select View → Vertices.

1.2  In the manual I can see a "View" menubar item, but it doesn't appear when I start CFinder. Why?

Indeed, there is no "View" item when you start CFinder. Please open a network file (for example, one from the demo directory) and run CFinder on that network file. After the calculations have been finished there should be a "View" menu item between "File" and "Tools". If you don't see the "View" menu item after the calculations, then please let us know and we will look into this. (We thank Chirag Gupta for asking us to clarify this feature of CFinder.)

1.3  How can I use the graph widget of CFinder v1? I want to avoid the dynamic layout.

The widget of version 1 is available in the CFinder version 2: click on Tools -> Settings, and unselect use prefuse widget, (don't forget to click apply and ok).

1.4  Every time I export a graph, when I open the file it is just a blank page. This happens whatever format I choose for the export (pdf, jpeg, bmp etc...)

One thing that might be an issue is that the export function should export the visible part of the graph, i.e. what is visible in the window. If that part of the window is too small, or the graph lies outside of it, it will export an empty image.

1.5  I can run the command line version but I receive java related errors when I use the graphical user interface.

We highly recommend sun java.

If you have more than one java runtime environment installed on your computer, check whether CFinder would be run with sun java. Read the output of the command java -version. With sun java, it should print something like (version numbers or 64-bit/32-bit may be different):

java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) 64-Bit Server VM (build 14.0-b16, mixed mode)

Note: you might be able to set the full path to the sun java JRE in the start.sh or start.bat launcher script in CFinder's directory.

You can test your java configuration directly from your browser as well. If you click here and your java is set up correctly, the graphical user interface of CFinder should start and show you a small example community structure.

Linux (ubuntu etc):

To install the sun java runtime environment on ubuntu, follow the description at https://help.ubuntu.com/community/Java (specifically, this part: "To get Sun Java under Ubuntu 7.04 or later running on Intel or PowerPC platform, you should enable the Universe repository in Add/Remove programs, and install either the openjdk-6-jre package or the sun-java6-bin package.")

note: If you don't want to set the sun java JRE as default system-wide (with update-java-alternatives), you might be able to set the full path to the sun java JRE (/usr/lib/jvm/java-6-sun/jre/bin/java) in the start.sh launcher script in CFinder's directory.

1.6  I experience some problem with the CFinder graphical user interface, but I cannot figure out what is the real problem, and I do not know how to report it.

You could try running the CFinder gui from the command line, and send us the error messages it prints (note that it will print many non-error diagnostic messages as well).

under MAC OS:

To run the CFinder gui from the command line, find CFinder.app.

(If you "installed" CFinder by dragging it to the Applications folder, it should be somewhere there, if you are simply running it from the .dmg, then it should be around /Volumes/CFinder/CFinder.app).

Open Terminal.app, cd to Contents/MacOS inside this CFinder.app, and run ./JavaApplicationStub. The CFinder gui should open, and you should see lines like "No parameters are loaded from parameter file" printed in Terminal.app.

Copy-paste what is printed in Terminal.app into a text document, and send us this text file.

2.  Usage

2.1  Exact clique finding takes too long. What shall I do?

  1. Use the command line version of CFinder included in the downloadable zip file. This version can run in the background.
  2. Use a lower and an upper threshold for link weights, then keep only the links with weights between these two thresholds.
  3. Set the lower link weight threshold to a very high value: just slightly below the highest link weight in your network. With this parameter setting CFinder will finish quickly. Now decrease the lower link weight threshold in subsequent little steps and after each step run CFinder again. As the lower link weight threshold is lowered more and more links of your network will be used for the community finding and the identified communities will grow. Based on the identified communities you may select a particular lower link weight threshold.
  4. Use the approximating community finding algorithm where you can set the maximal time allowed for clique search at each node. CFinder will only approximate the cliques in the parts of the network with the highest link density. With this option some of the computed communities will be exact, while others will be approximate communities. The names of approximate communities will be printed in italics at "View communities".
    Read about approximate clique finding >>

2.2  Can I run CFinder directly from another Linux program?

Yes, use CFinder_commandline or CFinder_commandline_64 . These files are included in the downloaded zip package.

2.3  Could you provide the java documentation of CFinder? I plan to call it through my own java code.

Using the CFinder libraries from a java program via jni (i.e. outside of the graphical or commandline CFinder program) is currently unsupported. As an alternative we suggest using the command-line version: java programs can call the executable and then resulting files can be parsed and interpreted again.

2.4  I have calculated the community structure on a big server, and I have problems with loading the results on my terminal

The lines of a text file on Linux, Mac, and Windows end usually with \n, \r, and \r\n, respectively.

  1. To convert a file from Linux/Unix to Windows format,
    • either try to read the file with WordPad on Windows and then save it as plain text file
    • or convert it on Linux with the unix2dos utility
  2. Make sure, that you are using the latest version of CFinder on both computers.
  3. Check, if your terminal has enough memory.
  4. If all else fails, you can send the name of your operating system and your input file to CFinder@hal.elte.hu. We will contact you with a suggested solution.

2.5  I receive a warning in the CFinder window: "user abort". What next?

2.6  How to get more output from CFinder, why my problem occures?

Check the console: e.g. the reason for the "user abort" message and debugging information are most likely printed to the console. In Windows this is the DOS window that is opened when the graphical CFinder is started. In Linux and Mac this is your xterm from which you started CFinder.

2.7  I have a huge graph that does not fit into the memory. What can I do?

Java message: User abort. Console: Stopped. java.lang.Exception: St9bad_alloc

  1. : Run the commandline version of cfinder on your network, since that would save some memory by avoiding the overhead of java and the memory used by the gui.
  2. : Try to use integer numbers to identify the nodes instead of long character strings. This can help a little.
  3. : Close other applications (web browser, X server etc).
  4. : Try to cut your graph into smaller parts: If there are unconnected parts, put these subgraphs into separate network files and analyse them separately.
  5. : Try to remove nodes, that have less first-neighbors than k, where k is your preferred minimal k size (k=3 in the most general case). Such cleaning can be done without loading the whole graph into the memory.
  6. : If nothing helps, as a last chance, you can send your graph to us. (if you can, please do not send the huge data file, instead send us a www link, where we can download your file from)

2.8  Under Windows x64 bit I get the message: C++ library not found or other library path problem

Unfortunately currently CFinder only supports 32bit Windows. 64 bit support is only available for Linux. This is due to the fact that the c++ library that does most of the calculation does not support 64 bit systems.

However, the current windows version of CFinder should work on 64 bit windows as well, if a 32 bit version of java is used. A 64 bit version of java will look for a 64 bit version of the c++ library, not find it, and give up with the error message.

2.9  Under windows I got the Error message: Exception in thread "main" java.lang.NoClassDefFoundError: elte/commuity/visual/MainFrame

You appear to be trying to use the start.sh script to start cfinder. However, that script is for unix-like systems (like linux). Under windows, the start.bat script should be used.

2.10  Can one supress the screen printed output of the CFinderBatch file?

The commandline program doesn't have such a switch. You can simply redirect the output to a file. This can be done with: ./CFinder_commandline ...other parameters.... > stdout_logfile 2>stderr_logfile

2.11  How can I export the picture, I see inside the display panel? What I got is only a blank page in the exported file.

Probably you are using a laptop. The mouse pad on some laptops are not reliable, and give some awkward signal if you click on it. Try to use an USB or PS2 mouse plugged into your laptop.

2.12  I received an error message about a licence file. I cannot use the software.

Error message if Licence expired.

Your initial licence has expired. Please read details in the Licence section here how to continue.

2.13  How do I find the common elements between overlapping communities?

Suppose your input file is network.txt. CFinder will put its output files in a subdirectory called network.txt_files under the same directory. Within that subdirectory you will find further subdirectories called k=3, k=4, etc., containing the results computed by CFinder for the specified k (clique size parameter) value. Within one such subdirectory the file communities will list the members of each community. Elements (nodes) listed in more than of the communities are the overlapping (shared) elements.

2.14  How can I set the intensity threshold for handling weighted (CPMw) networks?

Open CFinder and select "File" -> "New Community Finding". You will see the following items on your screen. In the "New Community Finding" dialog select "weighted (CPMw)" and enter the weight threshold.

Intensity threshold selection in CFinder.

3.  Input format

3.1  How can I construct a network with CFinder?

Note, that CFinder can identify communities in a network. The input file format is shown in the Manual.

3.2  I use MS Windows with Excel and my network is stored as an adjacency matrix. Can I convert it to a list of links? (This is the input format used by CFinder)

Yes. Please try this solution first: http://www.excelforum.com/excel-worksheet-functions/817157-convert-matrix-to-column.html. If this does not work for you, then please save the error message you get and send it to us: CFinder@hal.elte.hu.

3.3  I have tried the demo networks in the downloadable zip package. Do you have further networks?

Yes. Please go to http://CFinder.org/data for further input data files. Note that these files are large and should be used with the command-line (not graphical) version of CFinder.

If you want to construct the network you need a separate tool, or you can write your own program. We can help you with some examples, for futher details go to our data and scripts page and search for Perl script [small zip package]

3.4  I work with matlab. How should I export my graphs for CFinder?

You are working probably with sparse matrices as networks. Sparse matrices are defined by three vectors and two integers.
mynetwork=sparse(u,v,w,n,n)
where u, v and w are vectors of dimension n (for details check the matlab manual).

CFinder can read text files, so you have to export into this format. Try the following code:
 
y=[u;v;w];
fid2 = fopen('network.dat', 'wt');
fprintf(fid2, '%10d %10d %10.8f\n', y);
fclose(fid2);

This writes your vectors in the form, that CFinder can interpret as a weighted network.

Note, that u,v,w vectors are those variables, that you have used to create the sparse matrix representation of the network.

The second argument of fprintf can be in other form, if you have smaller networks or the weigths are in another regime.

3.5  I've opened one of the demo input files with NotePad and I see black boxes. What's wrong ?

This is how the top of the file looks if you open it with NotePad.

NotePad on Windows cannot read the "newline" characters of Linux files. It shows a black box instead. Try to open the file with WordPad or Microsoft Word.

This is how the top of the file looks if you open it with WordPad or Microsoft Word.

3.6  CFinder reads only the first line from the network file and then aborts.

Please check your input file with a text editor. It can happen, that your file appears to have only one single line, since the new line character in your file is not compatible with the operating system you are using. (A detailed explanation can be found on the wikipedia.)

You can convert your file with a text editor (e.g. Wordpad) or unde rlinux you can use the following command:
sed 's/\r/\n/g' your_input_file.txt > converted_file.txt

4.  Licence

4.1  As a non-profit user am I allowed to share files that I created with CFinder?

Under current U.S. law, file-sharing or the trading of works online is considered a commercial use -- even if no money changes hands. Because we believe that file-sharing, used properly, is a powerful tool for distribution and education, our license contains a special exception for file-sharing. The trading of works online is not a commercial use, under our documents, provided it is not done for monetary gain.

4.2  May I use the data sets from the CFinder website and from the downloaded version the demo files? Are they free for non-profit and for commercial usage?

For non-profit use all data sets are free and we ask that you cite our papers shown on the data download page.

For commercial use the data sets are not free. If you use the raw data sets (without our contributed cleaning and organizing work), please contact the authors of the original data. If you plan to use our contributed work please send details to CFinder@hal.elte.hu. According to the details we forward your question to the corresponding author or contributor.

4.3  Can you send me the source code of CFinder?

Currently the source code of CFinder is not open. You can find details about the algorithms in our publications:


For further details please see the list of publications.

4.4  My licence has expired. How can I uninstall CFinder?

If you use windows, you can simply delete the CFinder directory (which was created when you unzipped the zipfile you downloaded). On mac, simply delete the .dmg. If you have "installed" it by dragging the app to the Applications folder, simply delete it from there as well.

CFinder doesn't install any other components like start menu items or desktop icons, so no other uninstalling is needed.

4.5  My licence key has expired. How can I use your software?

Non-profit licenses can be requested at http://CFinder.org/key. If you would like to receive a for-profit licence, then please contact us at CFinder@hal.elte.hu.

4.6  Should I be categorized as a commercial user or a not-for-profit user? I use CFinder only for my personal interest in my free time.

You can use CFinder as a non-profit user for your own personal, company-independent research activities. If you make profit with your work for you or for your company, or you help somebody to earn profit with CFinder, you are a commercial user.